Introducción a ARREGLOS

Ingresar o Registrarse



Versión Estudiante

Introducción a ARREGLOS

NESTOR DARIO AGUDELO CORREA
Colombia - El Carmen De Atrato
IE CORAZON DE MARIA

Área

Tecnología e Informática - Informática

Edad

16-17+

Descripción

En este proyecto se estudiarán los arreglos a partir de el uso de las estructuras repetitivas o bucles llamada MIENTRAS QUE y PARA QUE; usando la herramienta pseint como editor de seudocódigos, que permitiran  hacer ejercicios con arreglos que permitan al estudiante almadenar datos en una variable utilizando un índice, de tal forma que sean guardados y almacenados para ser tratados como una unidad.

 


Objetivos

Comprender el concepto ARREGLO y aplicarlo en seudocódigos, manejar la herramienta de programación es su propio idioma llamada Pseint, utilizar la estructura MIENTRAS QUE y PARA QUE, para hacer arreglos


Duración

Sesión 1: 1 Sesión En el primer bloque de clase de 2 horas se puede desarrollar la primera actividad. 2 Sesión En el siguiente bloque de clase de 2 horas, se desarrollan las actividades 2 y 3.



Requisitos

Conocer la interfaz del programa pseint y su uso, conocer conceptos como: identificador, variables y constantes, tipos de datos, operadores aritméticas, lógicos y buleanos, expresiones arirtméticas, lógicas y buleanas; conocer la estructura del diseño de algoritmos en seudocódigo como son: entrada, salida, asignación; conocers las estructuras de los algoritmos como: estructuras simples, de dicisión, bucles MIENTRAS QUE y PARA QUE, la estructura de bifurcación CASO DE, 


Herramientas

Audio / Herramientas: recopilar información / Herramientas: tomar apuntes en clase / Imágenes / Páginas Web / Video / Libros Digitales /

Actividades de Clase

Sesión 1

Propósito

Actividad 1:

Hacer un diagnóstico de los prerequisitos necesarios para proceder con los temas siguientes como son: comprensión de las estructura repetitivas MIENTRAS QUE y PARA QUE; y los conceptos fundamentales como: variables, constantes, asignación, operadores aritméticos, de relación lógica y buleanos, expresiones aritméticas, lógicas y buleanas, entrada, salida y proceso en un algoritmo, definición de algoritmo.

Actividad 2: 

Conozmamos la aplicación Pseint, por medio de un vídeo y en la pantalla táctil, mostrar los elementos de la interfaz gráfica, el funcionamiento y el acceso a las herramientas y menús.

Actividad 3: 

Abra la aplicación Pseint, active los comandos en la parte derecha de la ventana como se mostró en la actividad anterior, dentro de las líneas Proceso y fin proceso escriba lo siguiente: 

Definir n, i como entero
    i=1;
    Escribir "Escriba un número";
    leer n;
        Mientras i<= n Hacer
            Escribir i;
            i=i+1;
        FinMientras

Utilice la herramienta de flecha como se indicó en la lección 2 para probar el ejercicio.

Ahora, escriba un enunciado que defina que hace el ejercicio anterior.

En esta oportunidad vamos a escribir un ejercicio usando el bucle PARA QUE:

Entre a Pseint y escriba el siguiente código entre las líneas Proceso y FinProceso:

Para i<-1 Hasta 5 Con Paso 1 Hacer
        Escribir i
Fin Para

Escriba el enunciado que defina qué hace el ejercicio anterior.

Duración

1 Sesión

En el primer bloque de clase de 2 horas se puede desarrollar la primera actividad.

2 Sesión

En el siguiente bloque de clase de 2 horas, se desarrollan las actividades 2 y 3.

Actividad Docente

Actividad del docente

1. Hacer las preguntas de la actividad 1, se hace una planilla con los nombres de los estudiantes y se coloca cada acierto de las preguntas y salidad al tablero de los estudiantes y respondan correctamente.

2. Los estudiantes que no acierten, deben hacer una exposicion de 3 temas del diagnóstico ante los demás estudiantes.

3. Todos los estudiantes deben hacer 3 ejercicios en donde se apliquen todos los temas del diagnóstico.

Actividad Estudiante

Actividad del estudiante

1. Todos los estudiantes deben participar en las preguntas de la prueba diagnóstica que será oral. 

2. Cada estudiante hace en el computador los dos ejercicios de la actividad 3.

3. Cada estudiante debe desarrollar en el cuaderno los tres ejercicios de la prueba diagnóstica y luego entregar el cuaderno para revisión al profesor


Evaluación

1. Entrar a la plataforma: www.virtual.iecorazondemaria.edu.co

2. Entrar a lecciones y desarrollar los test sobre prueba diágnostica


Notas

Algunos de los trabajos en este proyecto se deben desarrollar en la plataforma virtual de la institución, que es una LMS libre llamada Chamilo, cada estudiante registrado debe entrar con su usuario y contraseña


Creditos

Autor: NESTOR DARIO AGUDELO CORREA , Proyecto creado 9 de Octubre de 2019

  • Copiado por Nestor Dario Agudelo Correa
    el 9 de Octubre de 2019
    ahora es
  • Copiado por Nestor Dario Agudelo Correa
    el 9 de Octubre de 2019
    ahora es Introducción a ARREGLOS


URL:


Etiquetas:


Inicio | Registro | Quienes Somos | Edukatic | Políticas de Uso | Uso de datos personales | Universidad Icesi | RSS

Copyright: eduteka 2001-2017 | Desarrollado por Boris Sánchez Molano | Icons made by Freepik from www.flaticon.com